Как хорошо jQuery поддерживает обратную совместимость?

У нас были проблемы с Mootools, не являющимся очень обратно совместимым конкретно в области функциональности перетаскивания. Я задавался вопросом, были ли у кого-либо какие-либо подобные проблемы с jQuery, не являющимся обратно совместимым. Мы начинаем использовать его вполне в большой степени и думаем об обновлении до более новой версии, чтобы начать использовать несколько плагинов, которые требуют его. У нас будут какие-либо проблемы, если мы избавимся от более старой версии?

35
задан Josh Mein 16 September 2019 в 16:55
поделиться

2 ответа

jQuery, кажется, приятно обратно совместим. Я использовал его больше нескольких лет теперь через несколько версий ядра и не имел проблем при обновлении кроме нескольких незначительных с некоторыми плагинами. Я сказал бы, что ядро, кажется, прекрасно, но если Вы используете много плагинов, Вы могли бы столкнуться с некоторыми проблемами (но их обычно легко зафиксировать, или новому ядру встроили ту функциональность так или иначе, таким образом, можно просто отбросить их).

29
ответ дан Lindsay 27 November 2019 в 07:16
поделиться

jQuery так серьезно относится к назад совместимости, что они производят "назад совместимость" плагин для каждого выпуска: http://docs.jquery.com/Release:jQuery_1.2#jQuery_1.1_Compatibility_Plugin . Это позволило людям, которым не нужна назад совместимость, экономят на весе страницы.

18
ответ дан FriendOfFuture 27 November 2019 в 07:16
поделиться
Другие вопросы по тегам:

Похожие вопросы: